aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* Close a commentf/refactor-for-clarityJesse Vincent2017-10-021-1/+1
|
* astyleJesse Vincent2017-10-021-35/+35
|
* First pass at comments on the rest of the default sketchJesse Vincent2017-10-021-16/+54
|
* comment much of the default sketchJesse Vincent2017-10-021-3/+140
|
* We're not actually exposing BootKeyboard yet.Jesse Vincent2017-10-021-1/+0
|
* Move some LED color definitions to after the macro defnitions.Jesse Vincent2017-10-021-8/+14
| | | | It seems a little clearer.
* move the hopefully-going-away numpad keymap id definition closer toJesse Vincent2017-10-021-1/+1
| | | | where one can intuit why it's that number
* reorganize imports for a little more clarityJesse Vincent2017-10-021-2/+5
|
* whitespaceJesse Vincent2017-10-021-1/+1
|
* Refactor macro code to remove hand-coded numbers and make code a bit more ↵Jesse Vincent2017-10-021-14/+32
| | | | readable
* astyleJesse Vincent2017-10-021-2/+2
|
* Remove a couple of C preprocessor macros involved in the definition ofJesse Vincent2017-10-021-4/+3
| | | | keyboard macros, in the hope of making the code clearer
* DEBUG_SERIAL is unused. kill itJesse Vincent2017-10-021-2/+0
|
* replace a magic seeming constant with a macroJesse Vincent2017-10-021-1/+1
|
* decompose a conditional to make it easier to read and refactorJesse Vincent2017-10-021-3/+5
|
* Kaleidoscope.setup no longer takes an argumentJesse Vincent2017-10-021-1/+1
|
* change the name of a compiler macro to make it clear that it's an idJesse Vincent2017-10-021-2/+2
|
* rename our keymaps to be more consistent.Jesse Vincent2017-10-021-6/+6
| | | | | | I feel weird about putting the name before the word 'keymap', but this seems less confusing than explaining why KEYMAP_QWERTY and KEYMAP_STACKED are different kidns of entitites
* Merge pull request #14 from algernon/f/numlock-no-macroJesse Vincent2017-10-021-4/+2
|\ | | | | Updated to use the new NumLock plugin.
| * Updated to use the new NumLock pluginGergely Nagy2017-10-011-4/+2
| | | | | | | | | | | | | | The NumLock plugin works without a macro now, so we can simplify the factory firmware by just using `Key_KeypadNumLock`. Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* | add some notes to the end of the readme. Thanks to @Jennigma++Jesse Vincent2017-10-021-0/+10
|/
* A couple explanatory notes suggested by Jennifer LeighJesse Vincent2017-09-081-2/+5
|
* Merge pull request #13 from cdisselkoen/improved-flashing-docsGergely Nagy2017-08-271-1/+8
|\ | | | | Improve documentation related to flashing
| * Improve documentation related to flashingCraig Disselkoen2017-08-241-1/+8
|/ | | | In particular, add instructions for the Arduino IDE
* Point Makefile to new make rulesJesse Vincent2017-08-211-1/+1
|
* Merge pull request #12 from algernon/f/led-api-updateGergely Nagy2017-08-171-7/+7
|\ | | | | Updated to use the new LEDMode/LEDControl APIs
| * Updated to use the new LEDMode/LEDControl APIsGergely Nagy2017-08-161-7/+7
| | | | | | | | Signed-off-by: Gergely Nagy <kaleidoscope@gergo.csillger.hu>
* | add a note about customizing the location of the Arduino install on LinuxJesse Vincent2017-08-161-2/+5
| |
* | slight makefile tweaksJesse Vincent2017-08-161-2/+2
| |
* | a bit more tweaking to the readmeJesse Vincent2017-08-161-14/+24
| |
* | Reorganize makefile to avoid suggestions that Arduino lets you customizeJesse Vincent2017-08-161-25/+29
| | | | | | | | your sketchbook directory
* | fix a path in the makefileJesse Vincent2017-08-161-1/+1
| |
* | fix rendering of READMEJesse Vincent2017-08-161-0/+1
| |
* | A pass at cleaning up the install instructions and Makefile a bitJesse Vincent2017-08-162-18/+11
|/
* astylev1.13v1.12v1.11Jesse Vincent2017-08-131-12/+12
|
* We had the wrong key definition for what keyboards actually use as thev1.10Jesse Vincent2017-08-131-1/+1
| | | | 'menu'
* First pass at adding in the boot greeting plugin to make the LED keyJesse Vincent2017-08-131-2/+4
| | | | glow on boot
* Switch our mute key to Key_Mute in the hope that it works better on OSXJesse Vincent2017-08-071-1/+1
|
* Merge pull request #9 from algernon/h/fn-fn-numpad-lock-be-goneJesse Vincent2017-08-031-2/+2
|\ | | | | Turn the Fn keys into Keymap1_Momentary
| * Turn the Fn keys into Keymap1_MomentaryGergely Nagy2017-07-301-2/+2
|/ | | | | | | | | | | | | | | When both `Fn` keys are `KeymapNext_Momentary`, holding both would get us to the `NUMPAD` layer, which overrides the palm keys and turns them into `Keymap1_Momentary` keys. Thus, when releasing them, we would receive a release event for `Keymap1_Momentary`, not for `KeymapNext_Momentary`, and we'd be stuck on the `Numpad` layer until toggling it off. To avoid this scenario, change the `KeymapNext_Momentary` keys into `Keymap1_Momentary`, so we never reach the `NUMPAD` layer via the `Fn` keys. Fixes keyboardio/Kaleidoscope#151, with thanks to @chughes87 for the report! Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* Merge pull request #7 from algernon/h/readme-fixupsJesse Vincent2017-07-271-4/+3
|\ | | | | Small README fixups
| * README.md: Break a line in two, for better presentationGergely Nagy2017-07-271-2/+2
| | | | | | | | | | | | | | | | Lines in fenced code blocks are not automatically wrapped, and a long line can easily result in an embedded scroll bar to be shown. Because those look bad, and reading wrapped text is easier, break a long line into two lines. Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
| * Fix the build status image URLGergely Nagy2017-07-271-2/+1
|/ | | | Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>
* Add a first pass READMEJesse Vincent2017-07-261-0/+61
|
* Update makefile to fix issuesJesse Vincent2017-07-261-3/+4
|
* astyleJesse Vincent2017-07-251-2/+2
|
* Fix key repeat on Any. Port to new hid facade apiJesse Vincent2017-07-251-3/+7
|
* switch to new CamelCased' toggle functionsJesse Vincent2017-07-241-3/+3
|
* Merge pull request #5 from algernon/f/numlock-api-simplificationJesse Vincent2017-07-231-1/+2
|\ | | | | Update to work with an argument-less NumLock.toggle()
| * Update to work with an argument-less NumLock.toggle()Gergely Nagy2017-07-021-1/+2
|/ | | | Signed-off-by: Gergely Nagy <algernon@madhouse-project.org>