diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 14 |
1 files changed, 10 insertions, 4 deletions
@@ -1,10 +1,11 @@ [package] name = "bleusb" +description = "Send boot keyboard reports over I²C." version = "0.1.0" authors = ["Brian Cully <bjc@kublai.com>"] edition = "2018" - -# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html +license = "GPL-3.0-or-later" +repository = "https://github.com/bjc/bleusb.git" [dependencies] embedded-hal = "0.2" @@ -19,8 +20,13 @@ cortex-m-rt = "0.6" smart-leds-trait = "0.2" smart-leds = "0.2" apa102-spi = "0.2" +usb-host = "0.1" +bootkbd = "0.1" +atsamd-usb-host = { path = "../usbh/atsamd-usb-host" } [patch.crates-io] -#atsamd-hal = { git = "https://github.com/atsamd-rs/atsamd", rev = "97d55c19" } -#trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd", rev = "97d55c19" } +#atsamd-hal = { path = "../usbh/atsamd/hal" } trinket_m0 = { path = "../usbh/atsamd/boards/trinket_m0" } + +[features] +default = ["atsamd-usb-host/samd21e18a"] |