summaryrefslogtreecommitdiffstats
path: root/ble/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ble/Cargo.toml')
-rw-r--r--ble/Cargo.toml18
1 files changed, 1 insertions, 17 deletions
diff --git a/ble/Cargo.toml b/ble/Cargo.toml
index 865834c..d645057 100644
--- a/ble/Cargo.toml
+++ b/ble/Cargo.toml
@@ -15,7 +15,7 @@ embedded-hal = "0.2"
panic-semihosting = "~0.5"
nb = "~0.1"
log = "0.4"
-starb = "~0.2"
+starb = "~0.3"
clint = "~0.2"
cortex-m-semihosting = "~0.3"
bbqueue = "~0.3"
@@ -23,19 +23,3 @@ bbqueue = "~0.3"
[features]
default = ["rt", "rubble-nrf52/52840", "cortex-m/const-fn", "cortex-m/inline-asm"]
rt = ["nrf52840-hal/rt"]
-
-[patch.crates-io]
-nrf52840-hal = { path = "../../nrf52-hal/nrf52840-hal" }
-starb = { path = "../../usbh/starb" }
-rubble = { path = "../../rubble/rubble" }
-
-[profile.dev]
-incremental = false
-codegen-units = 1
-debug = true
-lto = false
-
-[profile.release]
-debug = true
-lto = true
-opt-level = "s"