diff options
author | Brian Cully <bjc@kublai.com> | 2019-08-06 16:31:34 -0400 |
---|---|---|
committer | Brian Cully <bjc@kublai.com> | 2019-08-06 16:31:34 -0400 |
commit | 392239c7f522acb7ca5847a48dd9ab2480242924 (patch) | |
tree | b02f1f568085ae1dcb3c33c780d49a8d1a77a2eb /Cargo.toml | |
parent | b0c6c4f9a45cf2b965acd3d10499e9df54929b36 (diff) | |
download | clint-392239c7f522acb7ca5847a48dd9ab2480242924.tar.gz clint-392239c7f522acb7ca5847a48dd9ab2480242924.zip |
Add compatibilty with rust-stable.
* Add feature flag for const-fn functionality, which simplifies some
things and lets this crate run on architectures where atomic CAS
isn't available (e.g., thumbv6).
* Remove `const fn` where necessary to compile under rust-stable.
* BREAKING CHANGE - Change signature of `Handler::replace` to take a
mutable borrow. This is required because the underlying type is
now a NonNull, which needs `mut`. The old behavior was never
desired, but a consequence of trying to avoid `Option` by using a
default handler.
* Use lazy_static crate for initialization of Handler/HandlerArray.
* Specify Sync for Handler. This is not amazing, since it isn't, but
it's necessary for initialization in static contexts inside
`lazy_static`. This should be fine, because any actual
manipulation of the handler is done in unsafe functions.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -14,12 +14,13 @@ readme = "README.md" cortex-m = "~0.6" cortex-m-rt = "~0.6" compiletest_rs = "~0.3" +lazy_static = "~1.3" [target.'cfg(all(target_arch = "arm", target_os = "none"))'.dependencies] cortex-m = "~0.6" [features] -default = ["isr-32"] +default = ["isr-32", "compiletest_rs/stable"] const-fn = [] # Number of ISR closures to hold in a HandlerTable. This is pretty |