aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-07-29 10:48:05 -0400
committerBrian Cully <bjc@kublai.com>2019-07-29 10:48:05 -0400
commitb0c6c4f9a45cf2b965acd3d10499e9df54929b36 (patch)
treec006650bfb2ff4e233241eb3d5d326cb222daa80 /Cargo.toml
parent9a34921b3310a32644ba1ba2e72b028f27d4a2b2 (diff)
downloadclint-b0c6c4f9a45cf2b965acd3d10499e9df54929b36.tar.gz
clint-b0c6c4f9a45cf2b965acd3d10499e9df54929b36.zip
WIP: Add `const-fn` feature to attempt support for stable toolchain.
To get this to work, either `FnMut` traits need to be allowed in `const fn` in stable, or `Handler::new` needs to be non-`const`.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1079e1d..6d6f192 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,6 +20,7 @@ cortex-m = "~0.6"
[features]
default = ["isr-32"]
+const-fn = []
# Number of ISR closures to hold in a HandlerTable. This is pretty
# clumsy, but doesn't require const generics.