aboutsummaryrefslogtreecommitdiffstats
path: root/app/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-08-04 14:19:25 -0400
committerBrian Cully <bjc@kublai.com>2019-08-04 14:19:25 -0400
commite405c474f5e0e94288191223de7ae0f31ae0b15f (patch)
tree4ca89a92f0c868eb8feae272513c1e924b834adc /app/Cargo.toml
parentabd478d9425dd2d4acd5b58202b1a95b73ff217b (diff)
downloadsamd21-demo-e405c474f5e0e94288191223de7ae0f31ae0b15f.tar.gz
samd21-demo-e405c474f5e0e94288191223de7ae0f31ae0b15f.zip
Migrate everything over to separate libraries.
* `usb-host` is the crate containing the HAL traits. * `bootkbd` is a crate for a bare-bones boot protocol keyboard driver. * `samd21-host` is a crate with an implementation of `usb-host` for a SAMD21 platform, with an example for the trinket-m0 which uses the `bootkbd` driver to print keyboard reports.
Diffstat (limited to 'app/Cargo.toml')
-rw-r--r--app/Cargo.toml27
1 files changed, 0 insertions, 27 deletions
diff --git a/app/Cargo.toml b/app/Cargo.toml
deleted file mode 100644
index 1bf5ab8..0000000
--- a/app/Cargo.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-[package]
-name = "samd21-demo"
-version = "0.1.0"
-authors = ["Brian Cully <bjc@kublai.com>"]
-edition = "2018"
-readme = "../README.md"
-license = "GPL-3.0-or-later"
-
-[dependencies]
-rb = { path = "../rb" }
-usbh = { path = "../usbh" }
-
-trinket_m0 = { path = "../../atsamd/boards/trinket_m0" }
-clint = { path = "../../clint" }
-
-panic-halt = "~0.2"
-smart-leds = "~0.2"
-smart-leds-trait = "~0.2"
-apa102-spi = "~0.2" # DotStar driver.
-nb = "~0.1"
-cortex-m = "~0.6"
-cortex-m-rt = "~0.6"
-embedded-hal = "~0.2"
-log = { version = "~0.4", features = ["max_level_trace", "release_max_level_warn"] }
-
-[features]
-default = ["cortex-m/const-fn"]