aboutsummaryrefslogtreecommitdiffstats
path: root/samd21-host/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-08-04 14:19:25 -0400
committerBrian Cully <bjc@kublai.com>2019-08-04 14:19:25 -0400
commite405c474f5e0e94288191223de7ae0f31ae0b15f (patch)
tree4ca89a92f0c868eb8feae272513c1e924b834adc /samd21-host/Cargo.toml
parentabd478d9425dd2d4acd5b58202b1a95b73ff217b (diff)
downloadsamd21-demo-e405c474f5e0e94288191223de7ae0f31ae0b15f.tar.gz
samd21-demo-e405c474f5e0e94288191223de7ae0f31ae0b15f.zip
Migrate everything over to separate libraries.
* `usb-host` is the crate containing the HAL traits. * `bootkbd` is a crate for a bare-bones boot protocol keyboard driver. * `samd21-host` is a crate with an implementation of `usb-host` for a SAMD21 platform, with an example for the trinket-m0 which uses the `bootkbd` driver to print keyboard reports.
Diffstat (limited to 'samd21-host/Cargo.toml')
-rw-r--r--samd21-host/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/samd21-host/Cargo.toml b/samd21-host/Cargo.toml
new file mode 100644
index 0000000..446bf1d
--- /dev/null
+++ b/samd21-host/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "samd21-host"
+version = "0.1.0"
+authors = ["Brian Cully <bjc@kublai.com>"]
+edition = "2018"
+license = "GPL-3.0-or-later"
+
+[dependencies]
+usb-host = { path = "../usb-host" }
+rb = { path = "../rb" }
+log = "~0.4"
+embedded-hal = "~0.2"
+atsamd-hal = { path = "../../atsamd/hal" }
+
+[dev-dependencies]
+bootkbd = { path = "../bootkbd" }
+clint = { path = "../../clint" }
+cortex-m = "~0.6"
+cortex-m-rt = "~0.6"
+nb = "~0.1"
+trinket_m0 = { path = "../../atsamd/boards/trinket_m0" }
+
+[features]
+default = ["atsamd-hal/samd21e18a"]