aboutsummaryrefslogtreecommitdiffstats
path: root/samd21-host/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'samd21-host/Cargo.toml')
-rw-r--r--samd21-host/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/samd21-host/Cargo.toml b/samd21-host/Cargo.toml
new file mode 100644
index 0000000..446bf1d
--- /dev/null
+++ b/samd21-host/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "samd21-host"
+version = "0.1.0"
+authors = ["Brian Cully <bjc@kublai.com>"]
+edition = "2018"
+license = "GPL-3.0-or-later"
+
+[dependencies]
+usb-host = { path = "../usb-host" }
+rb = { path = "../rb" }
+log = "~0.4"
+embedded-hal = "~0.2"
+atsamd-hal = { path = "../../atsamd/hal" }
+
+[dev-dependencies]
+bootkbd = { path = "../bootkbd" }
+clint = { path = "../../clint" }
+cortex-m = "~0.6"
+cortex-m-rt = "~0.6"
+nb = "~0.1"
+trinket_m0 = { path = "../../atsamd/boards/trinket_m0" }
+
+[features]
+default = ["atsamd-hal/samd21e18a"]