aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-08-18 08:36:31 -0400
committerBrian Cully <bjc@kublai.com>2019-08-18 08:36:31 -0400
commit54acc36f96922c5f7eeb969313c9a556101f5b7b (patch)
tree06919c5b91d56e52e763342c92c5c550abbeb321 /Cargo.toml
parent45e0334a404cf4e155f483e7ad82232b15e4d475 (diff)
downloadatsamd-usb-host-54acc36f96922c5f7eeb969313c9a556101f5b7b.tar.gz
atsamd-usb-host-54acc36f96922c5f7eeb969313c9a556101f5b7b.zip
Fix `cargo test` by removing example.
Unfortunate, but necessary for automated testing. Documentation will need to be added to show usage, and a demo crate.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 1 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b2be984..413a676 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,17 +17,8 @@ log = "~0.4"
embedded-hal = "~0.2"
atsamd-hal = "~0.5"
-[dev-dependencies]
-bootkbd = "~0.1"
-clint = "~0.2"
-cortex-m = "~0.6"
-cortex-m-rt = "~0.6"
-nb = "~0.1"
-trinket_m0 = "~0.3"
-
[patch.crates-io]
-atsamd-hal = { git = "https://github.com/atsamd-rs/atsamd.git" }
-trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd.git" }
+atsamd-hal = { git = "https://github.com/atsamd-rs/atsamd.git", rev = "d1872cf" }
# Need to re-export features from atsamd-hal. If there were a
# compelling reason to merge this into there, this is it.