aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 11 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9e1bdcb..0ecc199 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ usb-host = "~0.1"
starb = "~0.1"
log = "~0.4"
embedded-hal = "~0.2"
-atsamd-hal = "~0.6"
+atsamd-hal = "~0.5"
[dev-dependencies]
bootkbd = "~0.1"
@@ -28,3 +28,13 @@ trinket_m0 = "~0.4"
[patch.crates-io]
atsamd-hal = { git = "https://github.com/atsamd-rs/atsamd", rev = "97d55c19" }
trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd", rev = "97d55c19" }
+
+# Need to re-export features from atsamd-hal. If there were a
+# compelling reason to merge this into there, this is it.
+[features]
+samd21g18a = ["atsamd-hal/samd21g18a"]
+samd21e18a = ["atsamd-hal/samd21e18a"]
+samd51 = [] # Convenience feature for shared configuration of samd51 chips.
+samd51g19a = ["atsamd-hal/samd51g19a"]
+samd51j19a = ["atsamd-hal/samd51j19a"]
+samd51j20a = ["atsamd-hal/samd51j20a"]