summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-08-06 08:53:42 -0400
committerBrian Cully <bjc@kublai.com>2019-08-06 08:53:42 -0400
commit9ff9f51c07f7226d6467bc9db608cc53c82365bd (patch)
treed3c9d83d24ba0c3ce29cab011deba5c4698e26e9 /Cargo.toml
downloadbleusb-9ff9f51c07f7226d6467bc9db608cc53c82365bd.tar.gz
bleusb-9ff9f51c07f7226d6467bc9db608cc53c82365bd.zip
Initial commit.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..003cfcb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "bleusb"
+version = "0.1.0"
+authors = ["Brian Cully <bjc@kublai.com>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+embedded-hal = "0.2"
+#atsamd-hal = "0.6"
+trinket_m0 = "0.4"
+log = "0.4"
+starb = "0.1"
+clint = "0.2"
+nb = "0.1"
+cortex-m = "0.6"
+cortex-m-rt = "0.6"
+smart-leds-trait = "0.2"
+smart-leds = "0.2"
+apa102-spi = "0.2"
+
+[patch.crates-io]
+#atsamd-hal = { git = "https://github.com/atsamd-rs/atsamd", rev = "97d55c19" }
+trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd", rev = "97d55c19" }