summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 8 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8bd6439..d5535a9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,7 +9,6 @@ repository = "https://github.com/bjc/bleusb.git"
[dependencies]
embedded-hal = "0.2"
-#atsamd-hal = "0.6"
trinket_m0 = "0.4"
log = "0.4"
starb = "0.1"
@@ -22,11 +21,16 @@ smart-leds = "0.2"
apa102-spi = "0.2"
usb-host = "0.1"
bootkbd = "0.1"
-atsamd-usb-host = { path = "../usbh/atsamd-usb-host" }
+atsamd-usb-host = { git = "https://github.com/bjc/atsamd-usb-host.git", rev = "385efdf53fa3fe38591f22d01edf75d3087c2326" }
+# atsamd-usb-host = { path = "../usbh/atsamd-usb-host" }
[patch.crates-io]
-#atsamd-hal = { path = "../usbh/atsamd/hal" }
-trinket_m0 = { path = "../usbh/atsamd/boards/trinket_m0" }
+bootkbd = { git = "https://github.com/bjc/bootkbd.git", rev = "49827fce5adbaf636b893919f31c0dbd97bb3eb4" }
+usb-host = { git = "https://github.com/bjc/usb-host.git", rev = "b0be48424e81384de3280b5a5ac521d694b82e15" }
+trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd.git", rev = "53f8d846e40715c8592d171d9a57b66ee303207a" }
+# trinket_m0 = { path = "../usbh/atsamd/boards/trinket_m0" }
+# bootkbd = { path = "../usbh/bootkbd" }
+# usb-host = { path = "../usbh/usb-host" }
[features]
default = ["atsamd-usb-host/samd21e18a"]