summaryrefslogtreecommitdiffstats
path: root/ble/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ble/Cargo.toml')
-rw-r--r--ble/Cargo.toml10
1 files changed, 7 insertions, 3 deletions
diff --git a/ble/Cargo.toml b/ble/Cargo.toml
index be54397..ad7b888 100644
--- a/ble/Cargo.toml
+++ b/ble/Cargo.toml
@@ -4,15 +4,19 @@ version = "0.1.0"
authors = ["Brian Cully <bjc@kublai.com>"]
edition = "2018"
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
[dependencies]
+nrf52840-mdk-bsp = { path = "../../nrf52-hal/boards/nrf52840-mdk" }
nrf52840-hal = "0.8"
rubble = "0.0"
rubble-nrf52 = "0.0"
+cortex-m = "~0.6"
+cortex-m-rt = "~0.6"
+panic-semihosting = "~0.5"
+nb = "~0.1"
[features]
-default = ["rubble-nrf52/52840"]
+default = ["rt", "rubble-nrf52/52840"]
+rt = ["nrf52840-hal/rt"]
[patch.crates-io]
nrf52840-hal = { path = "../../nrf52-hal/nrf52840-hal" }