summaryrefslogtreecommitdiffstats
path: root/ble/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ble/Cargo.toml')
-rw-r--r--ble/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/ble/Cargo.toml b/ble/Cargo.toml
index ad7b888..ad11b18 100644
--- a/ble/Cargo.toml
+++ b/ble/Cargo.toml
@@ -11,8 +11,13 @@ rubble = "0.0"
rubble-nrf52 = "0.0"
cortex-m = "~0.6"
cortex-m-rt = "~0.6"
+embedded-hal = "0.2"
panic-semihosting = "~0.5"
nb = "~0.1"
+log = "0.4"
+starb = "0.1"
+clint = "0.2"
+cortex-m-semihosting = "0.3"
[features]
default = ["rt", "rubble-nrf52/52840"]
@@ -20,3 +25,14 @@ rt = ["nrf52840-hal/rt"]
[patch.crates-io]
nrf52840-hal = { path = "../../nrf52-hal/nrf52840-hal" }
+
+[profile.dev]
+incremental = false
+codegen-units = 1
+debug = true
+lto = false
+
+[profile.release]
+debug = true
+lto = true
+opt-level = "s"