summaryrefslogtreecommitdiffstats
path: root/usb/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'usb/Cargo.toml')
-rw-r--r--usb/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/usb/Cargo.toml b/usb/Cargo.toml
new file mode 100644
index 0000000..a1978dd
--- /dev/null
+++ b/usb/Cargo.toml
@@ -0,0 +1,36 @@
+[package]
+name = "bleusb"
+description = "Send boot keyboard reports over I²C."
+version = "0.1.0"
+authors = ["Brian Cully <bjc@kublai.com>"]
+edition = "2018"
+license = "GPL-3.0-or-later"
+repository = "https://github.com/bjc/bleusb.git"
+
+[dependencies]
+embedded-hal = "0.2"
+trinket_m0 = "0.4"
+log = "0.4"
+starb = "0.1"
+clint = "0.2"
+nb = "0.1"
+cortex-m = "0.6"
+cortex-m-rt = "0.6"
+smart-leds-trait = "0.2"
+smart-leds = "0.2"
+apa102-spi = "0.2"
+usb-host = "0.1"
+bootkbd = "0.2"
+#atsamd-usb-host = { git = "https://github.com/bjc/atsamd-usb-host.git", rev = "385efdf53fa3fe38591f22d01edf75d3087c2326" }
+atsamd-usb-host = { path = "../../usbh/atsamd-usb-host" }
+
+[patch.crates-io]
+#bootkbd = { git = "https://github.com/bjc/bootkbd.git", rev = "49827fce5adbaf636b893919f31c0dbd97bb3eb4" }
+#usb-host = { git = "https://github.com/bjc/usb-host.git", rev = "b0be48424e81384de3280b5a5ac521d694b82e15" }
+#trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd.git", rev = "53f8d846e40715c8592d171d9a57b66ee303207a" }
+trinket_m0 = { path = "../../usbh/atsamd/boards/trinket_m0" }
+bootkbd = { path = "../../usbh/bootkbd" }
+usb-host = { path = "../../usbh/usb-host" }
+
+[features]
+default = ["atsamd-usb-host/samd21e18a"]