summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorBrian Cully <bjc@spork.org>2025-03-08 12:06:09 -0500
committerBrian Cully <bjc@spork.org>2025-03-08 12:06:09 -0500
commit496fd9b1d8247e67cc830bd4e49f479d464a1d8a (patch)
treed9881eb3341ffbc428c1a51c9ca36329481f188f /shell.nix
parentddc2818c6a096db5ff4db91f6538bf829043e563 (diff)
downloadchords-496fd9b1d8247e67cc830bd4e49f479d464a1d8a.tar.gz
chords-496fd9b1d8247e67cc830bd4e49f479d464a1d8a.zip
infra: initial infra
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..8863b3e
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,11 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.mkShellNoCC {
+ packages = with pkgs; [
+ gnumake
+ python3
+ typescript-language-server
+ ];
+
+ TMPDIR = "/tmp"; # lsp needs it
+}