diff options
author | Brian Cully <bjc@kublai.com> | 2019-05-10 11:50:53 -0400 |
---|---|---|
committer | Brian Cully <bjc@kublai.com> | 2019-06-03 09:23:29 -0400 |
commit | 5781e9391fe3d7d3dabec620cb782d38f5f9cb9e (patch) | |
tree | 9ed0b09fd40f128733e8441fc63f91a9ee17d3f6 /Cargo.toml | |
parent | f12811a0a5e15b596a0cc06c095832a6b795172b (diff) | |
download | clint-0.2.0.tar.gz clint-0.2.0.zip |
Update to 0.2.0: Add HandlerArray type.v0.2.0
* Create HandlerArray as a safe wrapper around Handler.
* Add Cargo features for HandlerArray size.
* Move Handler into sub-module.
* Add CriticalSection sub-module for architecture dependent support
of interrupt-free contexts.
* Add build rules to pull in cortex-m support for CriticalSection
automatically.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 17 |
1 files changed, 16 insertions, 1 deletions
@@ -1,6 +1,6 @@ [package] name = "clint" -version = "0.1.0" +version = "0.2.0" description = "CLosure INTerrupt handlers." categories = ["no-std", "embedded", "hardware-support", "asynchronous"] keywords = ["interrupt", "peripheral"] @@ -15,3 +15,18 @@ compiletest_rs = "~0.3" [dev-dependencies.cortex-m-rt] version = "~0.6" + +[target.'cfg(all(target_arch = "arm", target_os = "none"))'.dependencies] +cortex-m = "~0.6" + +[features] +default = ["isr-32"] + +# Number of ISR closures to hold in a HandlerTable. This is pretty +# clumsy, but doesn't require const generics. +isr-8 = [] +isr-16 = [] +isr-32 = [] +isr-64 = [] +isr-128 = [] +isr-256 = [] |