aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..21623b4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "clint"
+version = "0.1.0"
+description = "CLosure INTerrupt handlers."
+categories = ["no-std", "embedded", "hardware-support", "asynchronous"]
+keywords = ["interrupt", "peripheral"]
+license = "LGPL-3.0-or-later"
+authors = ["Brian Cully <bjc@kublai.com>"]
+repository = "https://github.com/bjc/clint"
+edition = "2018"
+
+[dev-dependencies]
+cortex-m = "~0.6"
+compiletest_rs = "~0.3"
+
+[dev-dependencies.cortex-m-rt]
+version = "~0.6"