aboutsummaryrefslogtreecommitdiffstats
path: root/app/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-06-24 21:14:32 -0400
committerBrian Cully <bjc@kublai.com>2019-07-23 19:55:18 -0400
commit63d4ce8154eb8f6feb67986e98ea9b5007632460 (patch)
tree187e66104eb7c848dcf73a5ee067c5f27235360a /app/Cargo.toml
downloadsamd21-demo-63d4ce8154eb8f6feb67986e98ea9b5007632460.tar.gz
samd21-demo-63d4ce8154eb8f6feb67986e98ea9b5007632460.zip
Initial commit.
Diffstat (limited to 'app/Cargo.toml')
-rw-r--r--app/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/app/Cargo.toml b/app/Cargo.toml
new file mode 100644
index 0000000..fd96c1a
--- /dev/null
+++ b/app/Cargo.toml
@@ -0,0 +1,27 @@
+[package]
+name = "samd21-demo"
+version = "0.1.0"
+authors = ["Brian Cully <bjc@kublai.com>"]
+edition = "2018"
+readme = "../README.md"
+license = "GPL-3.0-or-later"
+license-file = "../COPYING"
+
+[dependencies]
+trinket_m0 = { path = "../../atsamd/boards/trinket_m0" }
+panic-halt = "~0.2"
+smart-leds = "~0.2"
+smart-leds-trait = "~0.2"
+apa102-spi = "~0.2" # DotStar driver.
+nb = "~0.1"
+cortex-m = "~0.6"
+cortex-m-rt = "~0.6"
+embedded-hal = "~0.2"
+clint = { path = "../../clint" }
+#cortex-m-semihosting = "~0.3"
+bare-metal = "~0.2"
+rb = { path = "../rb" }
+vcell = "~0.1"
+
+[features]
+default = ["cortex-m/const-fn"]