aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-08-15 15:04:07 -0400
committerBrian Cully <bjc@kublai.com>2019-09-02 11:42:29 -0400
commit0654e10d0078955d6917db504ee5947846d4f952 (patch)
tree6420567ff130614dff2185b77d580efa6593cc87 /Cargo.toml
parentf15d28f86333d869b3ef0aaba10f4d720725bce5 (diff)
downloadstarb-0654e10d0078955d6917db504ee5947846d4f952.tar.gz
starb-0654e10d0078955d6917db504ee5947846d4f952.zip
Remove `Sync` marker for Reader/Writer.v0.3.0
These are not sync, as they can only be used from one thread at a time. Also add a `Send` trait for `RingBuffer`, as long as its element type is also `Send`.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 28e5c6b..bebb670 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "starb"
description = "STAtic Ring Buffers."
-version = "0.2.0"
+version = "0.3.0"
authors = ["Brian Cully <bjc@kublai.com>"]
edition = "2018"
license = "LGPL-3.0-or-later"