summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-09-09 20:15:21 -0400
committerBrian Cully <bjc@kublai.com>2019-09-09 20:45:08 -0400
commitc1422f40d1ec9f77cc72c9425e67e97150bb2f52 (patch)
treec1756087df282369ba856b1c384ef061af12f63e /Cargo.toml
parentfdd4cfd1eb4995c192184aaa6ff073cee50852cb (diff)
downloadbleusb-c1422f40d1ec9f77cc72c9425e67e97150bb2f52.tar.gz
bleusb-c1422f40d1ec9f77cc72c9425e67e97150bb2f52.zip
Convert to workspace.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..aa2710d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,25 @@
+[workspace]
+members = ["usb", "ble"]
+
+[patch.crates-io]
+#atsamd-hal = { path = "../usbh/atsamd/hal" }
+#trinket_m0 = { path = "../usbh/atsamd/boards/trinket_m0" }
+#feather_m0 = { path = "../usbh/atsamd/boards/feather_m0" }
+rubble = { path = "../rubble/rubble" }
+nrf52840-hal = { path = "../nrf52-hal/nrf52840-hal" }
+bootkbd = { path = "../usbh/bootkbd" }
+usb-host = { path = "../usbh/usb-host" }
+starb = { path = "../usbh/starb" }
+
+[profile.dev]
+incremental = false
+codegen-units = 1
+debug = true
+lto = false
+panic = "abort"
+
+[profile.release]
+debug = true
+lto = true
+opt-level = "s"
+panic = 'abort'