summaryrefslogtreecommitdiffstats
path: root/usb/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'usb/Cargo.toml')
-rw-r--r--usb/Cargo.toml22
1 files changed, 7 insertions, 15 deletions
diff --git a/usb/Cargo.toml b/usb/Cargo.toml
index 3a12676..fb6712c 100644
--- a/usb/Cargo.toml
+++ b/usb/Cargo.toml
@@ -9,9 +9,8 @@ repository = "https://github.com/bjc/bleusb.git"
[dependencies]
embedded-hal = "0.2"
-trinket_m0 = "0.4"
log = "0.4"
-starb = "0.2"
+starb = "0.3"
clint = "0.2"
nb = "0.1"
cortex-m = "0.6"
@@ -21,19 +20,12 @@ smart-leds = "0.2"
apa102-spi = "0.2"
usb-host = "0.1"
bootkbd = "0.2"
-#atsamd-usb-host = { git = "https://github.com/bjc/atsamd-usb-host.git", rev = "385efdf53fa3fe38591f22d01edf75d3087c2326" }
atsamd-usb-host = { path = "../../usbh/atsamd-usb-host" }
-
-[patch.crates-io]
-#atsamd-hal = { git = "https://github.com/atsamd-rs/atsamd.git", rev = "ce2c2f426" }
-#bootkbd = { git = "https://github.com/bjc/bootkbd.git", rev = "49827fce5adbaf636b893919f31c0dbd97bb3eb4" }
-#usb-host = { git = "https://github.com/bjc/usb-host.git", rev = "b0be48424e81384de3280b5a5ac521d694b82e15" }
-#trinket_m0 = { git = "https://github.com/atsamd-rs/atsamd.git", rev = "53f8d846e40715c8592d171d9a57b66ee303207a" }
-atsamd-hal = { path = "../../usbh/atsamd/hal" }
-trinket_m0 = { path = "../../usbh/atsamd/boards/trinket_m0" }
-bootkbd = { path = "../../usbh/bootkbd" }
-usb-host = { path = "../../usbh/usb-host" }
-starb = { path = "../../usbh/starb" }
+#atsamd-usb-host = { git = "https://github.com/bjc/atsamd-usb-host.git", rev = "52d36ba" }
+trinket_m0 = {version = "0.5", optional = true }
+feather_m0 = {version = "0.5", optional = true }
[features]
-default = ["atsamd-usb-host/samd21e18a"]
+default = ["trinket-m0"]
+trinket-m0 = ["trinket_m0", "atsamd-usb-host/samd21e18a"]
+feather-m0 = ["feather_m0", "atsamd-usb-host/samd21g18a"]