aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2022-10-25 12:20:32 -0400
committerBrian Cully <bjc@kublai.com>2022-10-25 12:20:32 -0400
commit0c4eb964b015961e3c90e45ef498f6c7f89eddba (patch)
treeb0cc3b540e7123b45da044c73d1f47f98ce010ef /Cargo.toml
parent0f80c612d59c855a99073e583db339fe6a42b883 (diff)
downloadluchie-0c4eb964b015961e3c90e45ef498f6c7f89eddba.tar.gz
luchie-0c4eb964b015961e3c90e45ef498f6c7f89eddba.zip
convert to gd32f303 (stm32f103) bluepill variant
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 12 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ce3f550..e9238a4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,20 +17,23 @@ lto = true
codegen-units = 1
[dependencies]
-gd32vf103-pac = "0.4.0"
-gd32vf103xx-hal = "0.5.0"
-riscv = "0.8.0"
-riscv-rt = "0.9.0"
+cortex-m = "0.7.6"
+cortex-m-rt = "0.7.1"
nb = "1.0.0"
-embedded-hal = "0.2.7"
+panic-semihosting = "0.6.0"
usb-device = "0.2.9"
usbd-serial = "0.1.1"
+usbd-webusb = "1.0.2"
+embedded-hal = "0.2.7"
-[dependencies.synopsys-usb-otg]
-version = "0.3.0"
-features = ["riscv", "fs"]
+[dependencies.stm32f1xx-hal]
+version = "0.9"
+features = ["stm32f103", "stm32-usbd", "rt"]
[[bin]]
name = "luchie"
test = false
-bench = false \ No newline at end of file
+bench = false
+
+[patch.crates-io]
+#usb-device = { path = "../usb-device" }