aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml21
1 files changed, 12 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ce3f550..e9238a4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,20 +17,23 @@ lto = true
codegen-units = 1
[dependencies]
-gd32vf103-pac = "0.4.0"
-gd32vf103xx-hal = "0.5.0"
-riscv = "0.8.0"
-riscv-rt = "0.9.0"
+cortex-m = "0.7.6"
+cortex-m-rt = "0.7.1"
nb = "1.0.0"
-embedded-hal = "0.2.7"
+panic-semihosting = "0.6.0"
usb-device = "0.2.9"
usbd-serial = "0.1.1"
+usbd-webusb = "1.0.2"
+embedded-hal = "0.2.7"
-[dependencies.synopsys-usb-otg]
-version = "0.3.0"
-features = ["riscv", "fs"]
+[dependencies.stm32f1xx-hal]
+version = "0.9"
+features = ["stm32f103", "stm32-usbd", "rt"]
[[bin]]
name = "luchie"
test = false
-bench = false \ No newline at end of file
+bench = false
+
+[patch.crates-io]
+#usb-device = { path = "../usb-device" }