aboutsummaryrefslogtreecommitdiffstats
path: root/usbh/Cargo.toml
diff options
context:
space:
mode:
authorBrian Cully <bjc@kublai.com>2019-07-25 09:40:31 -0400
committerBrian Cully <bjc@kublai.com>2019-07-25 10:14:46 -0400
commit7966be1419d3eaa088ed83f95282383182585640 (patch)
tree3b7b09eb768d47e327035301f53f3bd23b7596f2 /usbh/Cargo.toml
parent5b48a5c2f5526f088187fa341f64368994c9f517 (diff)
downloadsamd21-demo-7966be1419d3eaa088ed83f95282383182585640.tar.gz
samd21-demo-7966be1419d3eaa088ed83f95282383182585640.zip
Move USB host stuff to separate crate.
Diffstat (limited to 'usbh/Cargo.toml')
-rw-r--r--usbh/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/usbh/Cargo.toml b/usbh/Cargo.toml
new file mode 100644
index 0000000..327772b
--- /dev/null
+++ b/usbh/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "usbh"
+version = "0.1.0"
+authors = ["Brian Cully <bjc@kublai.com>"]
+edition = "2018"
+
+[dependencies]
+rb = { path = "../rb" }
+atsamd-hal = { path = "../../atsamd/hal" }
+embedded-hal = "~0.2"
+log = "~0.4"
+vcell = "~0.1"
+
+[features]
+default = ["atsamd-hal/samd21e18a"]